Odd issue with Distortion Generator

A family of high-end analog DI and effects gear.
WienerDog
Posts: 15
Joined: Wed Mar 27, 2019 4:31 am

Odd issue with Distortion Generator

Post by WienerDog »

I picked up another DG module just recently but it had problems right from the get go. The guitar signal seemed to not be reaching the circuitry, as evidenced by the fact that the distortion threshold LED was not lighting up and there was no sound coming from the module. So I opened the module up to have a look. With the module powered on, I could see that one of the internal clipping LEDs was shining continuously. I lifted up the circuit board just a little bit and guess what: the LED stopped shining and the module worked fine. So it seems like something might be shorting out, though I’m not sure what. Perhaps a fix is to place some felt under the circuit board to prevent any shorting?
X100Ver10
Posts: 143
Joined: Mon Sep 18, 2017 2:49 pm

Re: Odd issue with Distortion Generator

Post by X100Ver10 »

SR&D started to install a round rubber bumper on the inside of the bottom cover below the transformer during later modules. I believe they did that because some of the solder joints of the transformer might have been grounding out on the cover.

I tried to attach a picture but I kept getting an HTTP Error message.
User avatar
rbc
Site Admin
Posts: 593
Joined: Sat Nov 23, 2013 10:01 pm
Location: Vicksburg MS, USA

Re: Odd issue with Distortion Generator

Post by rbc »

X100Ver10 wrote: Fri Oct 29, 2021 1:32 am I tried to attach a picture but I kept getting an HTTP Error message.
I'll troubleshoot that this weekend and see if I can fix it.
Keep rockman-gearup.com advertising free. Make a contribution: https://paypal.me/rockmangearup/5/