My rig

A dedicated forum for posting pictures and other information about Rockman rigs.
User avatar
darthoverdrive
Posts: 46
Joined: Tue Mar 25, 2014 1:39 pm
Location: Kansas

Re: My rig

Postby darthoverdrive » Thu Jan 04, 2018 6:00 pm

Yes the flat side of the LED is also the negative side (cathode) which has the shorter lead. On the picture it is the side marked with the black line.

I get the impression that the previous owner made some modifications to the unit. Shame they left it like that. Still it looks like a fun project for you.
Does anything else look out of place or missing?

Fireful0
Posts: 168
Joined: Sat Feb 18, 2017 6:00 pm

Re: My rig

Postby Fireful0 » Thu Jan 04, 2018 6:05 pm

darthoverdrive wrote:Yes the flat side of the LED is also the negative side (cathode) which has the shorter lead. On the picture it is the side marked with the black line.

I get the impression that the previous owner made some modifications to the unit. Shame they left it like that. Still it looks like a fun project for you.
Does anything else look out of place or missing?

Thanks for the info!
The dude put in 2 IC sockets that output to left and right side of the headphones. I removed one of them, as the X100 shell could't close very well around it. Decided to leave the other, as I didn't want to mess up the circuit board.
Everything else looks ok, though.
Still makes me mad that he removed those LEDs though. It doesn't even sound good now. The compressor is absolute garbage now.

Got some LEDs ordered, which should be here by Saturday.
This small project is costing me more than I originally thought it would. :lol:
Oh well, at least I am learning a ton. :)

Fireful0
Posts: 168
Joined: Sat Feb 18, 2017 6:00 pm

Re: My rig

Postby Fireful0 » Sat Jan 06, 2018 9:17 pm

Thanks for all of your help everybody!!!
Replacing the LEDs completely fixed my problem! Now this thing sounds like pure gold!
(And looks like it too, I gotta add) :D
ImageImage
Image
Image
Last edited by Fireful0 on Sun Jan 07, 2018 4:40 am, edited 1 time in total.

User avatar
rbc
Site Admin
Posts: 374
Joined: Sat Nov 23, 2013 10:01 pm
Location: Vicksburg MS, USA

Re: My rig

Postby rbc » Sat Jan 06, 2018 9:45 pm

That's great. I'm glad to hear you have it up and running now!
The rockman-gearup.com forum is community supported. Please consider making a contribution. Here’s the link: https://paypal.me/rockmangearup/5/

User avatar
darthoverdrive
Posts: 46
Joined: Tue Mar 25, 2014 1:39 pm
Location: Kansas

Re: My rig

Postby darthoverdrive » Sun Jan 07, 2018 12:00 am

Congratulations! Nothing like the feeling you get when playing with a piece of gear that you repaired yourself.

Fireful0
Posts: 168
Joined: Sat Feb 18, 2017 6:00 pm

Re: My rig

Postby Fireful0 » Sun Jan 07, 2018 12:05 am

Thanks guys!
I had a ton of fun!
Now to make some fun recordings with it. :)