Rockman Stereo Echo not functioning in ‘true stereo’

A family of high-end analog DI and effects gear.
Master Moss
Posts: 1
Joined: Sun Jun 30, 2019 2:31 pm

Rockman Stereo Echo not functioning in ‘true stereo’

Post by Master Moss » Sun Jun 30, 2019 3:55 pm

Salutations Rockman aficionados,

I’m a new member to this forum and this is my first post.

I recently purchased the Rockman Stereo Echo rockmodule unit from a seller on EBay. I discovered the Rockman line of effects and the Stereo Echo particularly almost two years ago when trying to find an all analog delay with stereo inputs and outputs. The Rockman was one of the only delay units ever made that had both of those features. I finally saw a good condition one come up for sale and had some disposable dough to make the purchase last week and it arrived 2 days ago.

I had my first opportunity to try it out yesterday and the quality of the delay/Echo sound is just as amazing as I had heard in the videos I’d seen demoing it.

However, I was disappointed to discover that my unit does not function in a truly ‘stereo’ fashion as I had expected. Though there are stereo inputs and outputs on the unit, it seems that the unit just functions like other ‘stereo’ analog effects boxes: What I mean by this is that it creates its stereo effect by taking a mono signal from a guitar or some other source and sending once copy of that signal to a left output and one copy of that signal to a right output and affecting the two differently. For the Stereo Echo, it puts one delay time to the signal to the left and one to the signal on the right. The delay times are affected with delay differences of a 3 to 5 ratio. So if one side is set at 300ms delay, the other has a 500ms delay time etc.

Now this does effectively take a mono source and make that signal stereo. But I can not understand why the unit bothered to have stereo inputs?

What I expected to happen was the following:

I would run an already stereo signal into the left and right stereo inputs of the Stereo Echo. Then, the stereo echo would apply one delay time to the left signal of of the stereo inputs and another different delay time to the right signal of the stereo inputs and then output both of those signals left and right. Thus you would go from already a stereo signal to a badass stereo delayed stereo signal.

My unit does not do this. Even though I’m plugged into both stereo inputs, the stereo echo still only takes one of the input signals and doubles it to left and right. Making the inclusion of stereo inputs pointless, as far as I can tell. Even if you are running into both left and right inputs with a different signal, it only takes one of (the one labeled mono input I believe) and doubles that one, ignoring the other input channel.

Is this supposed to happen?

Or is my unit in need of repair?

It makes little sense to me that Mr. Scholz, a highly meticulous genius, would bother to design in stereo input jacks into the module, then have the module still only take signal from one input and ‘stereo-ize’ that. If my signal is already stereo, I want it to maintain that when I add the additional delay to it, not mono-ize it by taking only one half of the signal and then copy the mono-ized signal to stereo-ize the mono signal.

Any information on this would be extremely helpful. This unit was not cheap and it does sound great for stereoizing a mono signal, but this design actually seriously limits the potential of this otherwise great unit. Additionally, if this is the intended/proper function of the unit, would it be possible to mod the stereo echo to do what I am describing?

Thanks in advance for any replies/insights.

-MM

RockmanCentralBob
Posts: 312
Joined: Fri Feb 06, 2015 2:10 am

Re: Rockman Stereo Echo not functioning in ‘true stereo’

Post by RockmanCentralBob » Sun Jun 30, 2019 9:52 pm

Rest assured your unit is working properly as designed.

There Stereo Echo was a pretty expensive unit in it's day (still is) because of how it was designed. If you were to open it up, you would see an awful lot of parts..... WAY more than a normal analog delay. This is because Tom took great care to make sure it sounded incredible. He implemented a commander circuit to reduce noise (a combination of a compressor before the delay section and then an expander after the circuit). This is pretty rare (due to the cost) from what I understand. He also added a series of regeneration circuits throughout the delay chain in order to get that reverb "wash" effect as opposed to a standard simple dry delay found in most units. Even still, there were some cost factors involved... to design it the way you are explaining would have required nearly doubling the parts. Dual compander circuits, dual delay chains, everything.

As for why it has stereo inputs, that's because the Stereo Chorus has stereo outputs. So the right channel of the Stereo Chorus is passed through the Stereo Echo unaffected while maintaining the stereo image from the Stereo Chorus. In reality, this is how a lot of effects are added during the mixdown process on a mixing board, often with time based effects in order to avoid what's called "aliasing". The effects are effectively added in parallel.

In practice in a standard Rockman guitar rig, you won't even notice that the right channel signal isn't being processed with the delay.
It'll sound just find when you plug into it.

The only place I can where this feature would really be necessary is if you were using it with a mixing board, where you have it patched in on a stereo effects send and returning the wet signal only, and you were sending it multiple instruments panned in the stereo spectrum and you wanted the delays to be in the same location in the stereo spectrum as the signal feeding it. I have a Boss SE-50 wired into my mixing board so I can do that, though I can't recall the last time I ever processed anything that way.

Anyway, I hope this comforts you knowing that your unit is working fine (at least in this respect).